Are you part of a user group and the file upload or control submission is not working? You can find more information and possible solutions here.
If the issue can not be solved in the ways suggested below or if you have any further questions, please reach out to our Support via the contact form or support@impero.com.
Situation
- You are responsible or a reviewer for a control as part of a group.
- You try to upload a file or submit the control but it is not working. It could be that nothing happens, or that a server related error message appears.
Cause
One of the features of our web application is user collaboration where multiple users (groups) can work on the same control activity at the same time. The cooperative mechanism is implemented via a WebSocket protocol.
In some instances, this protocol is blocked by a firewall.
How to proceed
To investigate whether this is the case here, you can take the following steps:
- Go to the respective control and open the inspection tool of your browser (CTRL + Shift + I)
- Go to “Console”
- Try to upload/submit again
If the blockage happens due to WebSockets, you should find a paragraph like this in the console:
In this case, please get in touch with your IT department so that the WebSockets block can be removed.
If the entry cannot be found or there are any other uncertainties, please don't hesitate to contact our Support.