- Help Center
- Troubleshooting
-
Getting Started
-
Knowledge Base
- General
- Dashboard
- Admin: Managing Control Programs
- Admin: Creating Controls - Defining Title and Description
- Admin: Creating Controls - Setting up Schedule
- Admin: Creating Controls - Assigning Responsibility
- Admin: Creating Controls - Setting Reminders
- Admin: Creating Controls - Designing Questions/Tasks
- Admin: Managing Controls and Monitoring Control Performance
- Admin: Consolidated View and Mass Update
- I am a Control Responsible
- I am a Control Reviewer
- Risk Management
- User Management
- Datasheet
- Reporting
- Impero Share
- Frequently Asked Questions
-
Integrations
-
Security
-
News & Releases
-
Support Ticket
-
Troubleshooting
Application Error
Situation
You receive the message “Application Error” within Impero: An unexpected application error ocurred. If the Problem persists, please report the problem and where it ocurred.
Cause
One possible cause is that the browser version you are using is outdated. You could therefore check which version you are using in your browser settings and update it if necessary or try using a different browser.
However, there are a number of other possible reasons for this message. Therefore, please do not hesitate to contact us.
How to proceed
Please reach out to our Support via the contact form or support@impero.com. It is particularly helpful if you send us as many details as possible, i.e. a description of the process steps that lead to the message, screenshots etc.