This error message can have several causes, here you can find an overview and possible solutions.
Access denied (403) due to missing access rights
Access denied (403) when trying to log in with SSO
Access denied (403) when trying to log in with SSO from a different network
Access denied (403) when trying to reset your password
If the issue can not be solved in the ways suggested below or if you have any further questions, please reach out to our Support via the contact form or support@impero.com.
Access denied (403) due to missing access rights
Situation
You can see the error message “Access denied (403)”, possibly also “Error communicating with the server, Request failed with status code 403” according to the screenshot below.
In the browser bar you can see the URL for a control program.
Cause
The user that is logged in does not have the access rights that are required for this program.
How to proceed
- Make sure that you are logged in with the correct user profile.
- You can contact the administrator or contact person for Impero within your organization and ask whether you can be assigned the corresponding access rights.
Access denied (403) when trying to log in with SSO
Situation
You can see the error message “Access denied (403)” when trying to log in via Single Sign-On (SSO).
In the browser bar you can see the URL of your Impero environment and the ending "api/single-sign-on".
Cause
The most common causes for this are:
- Your user is not yet entered in the SSO database or there is a discrepancy with the address stored in Impero.
-
Your address is registered correctly but access to the Impero application has not yet been activated.
How to proceed
You can reach out to your IT department to check this. If there is a discrepancy, the e-mail address can then be adjusted either in Impero or the SSO database.
Access denied (403) when trying to log in with SSO from a different network
Situation
You can see the error message “Access denied (403)” when trying to log in via Single Sign-On from certain networks, for example if you are working from home or with a VPN. This can also happen if you are working from a different end device.
Cause
It may be that your IT department has set up a conditional access policy for such networks or devices, which in some cases can lead to issues with SSO.
How to proceed
Please contact Impero Support via our contact form or support@impero.com so that the next steps can be discussed together.
Access denied (403) when trying to reset your password
Situation
On the login screen, you click on “Forgot your password”. After you have entered your e-mail address and clicked on “Send me an e-mail”, the error message “Error communicating with the server, Request failed with status code 403” appears.
Additionally, the reset screen might be grayed out:
Cause
The most common cause of this behavior is that the option to log in with a password is not activated in your user profile.
How to proceed
You can contact the administrator or contact person for Impero within your organization and ask whether can activate the option "Allow authentication by password" for your user.